Index Forums Plugins Support Webmaster plugin's suggestion makes reCapcha stop working

This topic contains 1 reply, has 2 voices, and was last updated by  Towhid 1 year, 11 months ago.

  • Author
    Posts
  • #1289

    Endre
    Participant

    I have discovered, that your WebMaster plugin suggests to disable the
    allow_url_fopen setting in php.ini. This, however made the reCapcha plugin
    stop functioning. Here’s the log entry which helped me find the cause of the
    problem:

    [Tue Apr 21 12:12:29 2015] [error] [client …] PHP Warning:
    file_get_contents(https://www.google.com/recaptcha/api/siteverify?...):
    failed to open stream: no suitable wrapper could be found in
    /var/www/question2answer-1.7/qa-plugin/recaptcha-captcha/recaptchalib.php on
    line 92, referer:
    http://…/index.php/register?to=

  • #1290

    Towhid
    Keymaster

    Thanks for reporting this issue. I’ve updated the plugin and added a notice to let them know about possible problem. notice:

    It’s reported that Google Captcha plugin requires this option to be on in order to work. so before disabling this option make sure that you are not using this product of other scripts that use include, require, and file_get_contents() interacting with external resources.

    your help is really appreciated.

You must be logged in to reply to this topic.